12 November 2019

How to change the version of the AL Language compiler

Microsoft released a new update to AL Language extension for VS Code. With this new update, the compiler does a few pre-checks before compiling the objects and packages them into a .app file. 

Most probably you will have to do minor changes to your extension codebase to work with the new compiler. Otherwise, you will end up in errors like below:


Waldo already posts a few tweets about this new update. 

If you are not ready to deal with these new warning or error messages, and simply want to compile with using the old version this blog post will help you. 

If you want to go back to a previous version of the AL Language compiler you can use the following method:

But make sure to go back to the latest version and resolve the error as soon as possible, since this is just a workaround.

Please provide your feedback with a comment. 
Thank you and Regards,
Tharanga Chandrasekara

No comments:

Post a Comment